Release of PrestaShop 1.7.3.4 and 1.6.1.20

Prestashop is available using 1 click install in Cloud Server cPanel and Cloud Server Webuzo. Contact us to find out our latest offers!

PrestaShop 1.7.3.4 and 1.6.1.20 are now available. These versions fix security and PHP compatiblity issues.

Since these versions fix security problems, we strongly encourage you to upgrade your shop as soon as possible.

The most notable fix for 1.7.3.x is:

  • Improve cookies encryption

Some of the most notable fixes for 1.6.1.x are:

  • Improve cookies encryption
  • Improve compatibility with PHP 7.1 and 7.2

Download PrestaShop now!

Here is the complete list of changes for 1.7.3.4

  • Core:
    • Improvement:
      • #9222: Improve cookie encryption

Here is the complete list of changes for 1.6.1.20

  • Back Office:
    • Bug fix:
      • #8724: PHP 7.2 compat – Fix fatal error
  • Front Office:
    • Bug fix:
      • #9126: Control if customer is the owner of the selected order in contact form
  • Core:
    • Improvement:
      • #9141: Use https no http employee class
      • #9218: Improve cookie encryption
  • Web Services:
    • Bug fix:
      • #8821: FIX PHP 7.1 compat in WebserviceOutputBuilder

Contributors to this patch versions, from both the Core team and the community at large: Pierre RAMBAUD, Pablo Borowicz, Axome, Jáchym Toušek, okom3pom, Thomas N. Thank you! Two of you contributed for the very first time, warm welcome 🙂

A very special thank to Charles Fol from Ambionics for the security report!

Since version 1.7.3.4 is a “patch” update to version 1.7.3.3, upgrading from any 1.7.3 version will be easy: features will work better, and modules & themes which worked fine on 1.7.3.x will work just as well with 1.7.3.3.
Upgrades from a standard 1.7.x version should work just as well.

This the same for 1.6.1.20 regarding 1.6.1.x versions.

Prestashop is available using 1 click install in Cloud Server cPanel and Cloud Server Webuzo. Contact us to find out our latest offers!

Comments are closed.